Back to overview
Resolved
show.fm support is down
Sep 1, 2026 at 9:51am UTC
Affected services
show.fm support
Resolved
Sep 1, 2026 at 10:54am UTC
We’re back! show.fm support is now up and running. Thanks for bearing with us.
Affected services
Created
Sep 1, 2026 at 9:51am UTC
We’re having some trouble with show.fm support. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services